fkjj.net
当前位置:首页 >> linux需要安装jDk吗 >>

linux需要安装jDk吗

jdk就是java开发工具,提供了java的api和java的运行时环境jre。 不一定需要装的呀,只要你不需要运行java的程序,就不用jdk。 需要java环境的,比如eclipse啊一些软件,不用这些需要jre的软件的话完全不用装jdk。

需要,这具体是的安装步骤http://jingyan.baidu.com/article/915fc4149e4c9a51394b20d6.html

不需要 自己安装一般 oracle安装包多数都是自己带的 另外 自己安装也简单 系统安装包里都有jdk 安装就一步命令 rpm -ivh xxx包名 就行了 希望采纳

JDK:Java Developing Kit,java软件开发包是所有java程序的基础,任何java程序的运行必须要jdk或者jre处理,tomcat作为只是构建在jdk上独立的servlet容器,如果脱离jdk底层的支持,肯定无法运行的 jdk:好比房子的主体结构 tomcat:可以理解为房子...

在linux安装好了jdk之后,在命令行窗口,通过输入javac,就会弹出如下信息: 出现上述信息之后,就可以确定jdk已经正确安装完成。

不需要的

一、软件下载 1、下载JDK(下面分别是32位系统和64位系统下的版本) http://download.oracle.com/otn-pub/java/jdk/7u9-b05/jdk-7u9-linux-i586.tar.gz?AuthParam=1350717577_c0836b48d7dc4cd4598cdd4f0d49e6f6 #32位 http://download.oracle.co...

这里有详细的图文教程http://jingyan.baidu.com/article/91f5db1b2a4a951c7e05e348.html

看看 是否设置了jdk环境变量: echo $JAVA_HOME; 或运行命令: java -verion 看看能否查看版本 ,能就是运行; 或者查看后台进程:ps -ef|grep java。 1 Linux 目录结构 即使这是个菜鸟级的问题,也经常难住老鸟。我就见过很资深的程序员把JDK不...

根据Java开发的要求来选择,比如说如果生产环境部署的是1.6版本的,而你用的是1.8版本开发的,1.8版本的某些Java新特性1.6版本并不支持,那就不能正常运行了;如果你是学习Java开发,想体验或者学习Java的新特性,那就安装一个1.8版本的。

网站首页 | 网站地图
All rights reserved Powered by www.fkjj.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com