fkjj.net
当前位置:首页 >> 代码能在xCoDE上运行,但不能在vC++6.0上运行 >>

代码能在xCoDE上运行,但不能在vC++6.0上运行

我可以运行啊,没错啊. 你把错误发出来看看是什么错

//for(int i = LIST_INIT_SIZE-1; i >= N ;i--)//因为C语言不能这样在函数内部声明,只能再函数头部声明,但是C++支持这种,你可以将文件后缀改成.cpp再编译就没问题了//望采纳#include #include #define LIST_INIT_SIZE 100#define LISTINCREME...

应该把不行的提示贴上啊

xcode编译器比vc严格很多,vc早就淘汰的产品了,自身就是一大堆bug,vs早顶替vc了,vs后期版本修复了不少已知的bug,但是类型检查之类的东西还是不严格,而且vs编译器一贯秉承了vc那种傻瓜式编程的风格,对于类型匹配、安全检查之类的东西,编译...

其实很简单,oc更接近c, 完全兼容posix。 c++ 没有这么接近c, 用的stdlib可能是微软重写的

VC上运行c语言程序时跳出来的是命令行窗口,Mac系统上对应命令行窗口的是终端,但是Xcode运行时不会调用终端,它是集成了一个运行窗口。

VC是微软开发的,只能在Windows平台才能运行,而Xcode是苹果开发的,只能在Mac下才能运行,两者完全是两回事啊,从VC到Xcode的跨度很大,函数没有什么相似性,如果你想问VC的什么功能在Xcode怎么实现应该可以告诉你,但是要找出函数在VC和Xcode...

VC++特指微软的Visual C++,用到的类库是MFC、Win32(6.0以前)或.NET(6.0以后) xcode与vc是两个完全不同的东西 至于你说的功能,任何库都可以实现近似的功能,但是用法上是完全不同的

VC6.0最开始应该是叫VS6 ,后来VC6从这里面单独抽了出来广为使用。Visual Studio是一个合集,VS2008也是如此,包含了很多编程语言,比如VC C# Vb等。其中VS2008的VC部分是叫VC9。 VS2008采用的函数库版本比较新,用的SDK3.0--3.5。比VC6做了优化...

不可以 vc是微软的产品,需要依赖微软的操作系统,和mac的底层和内核都不一样

网站首页 | 网站地图
All rights reserved Powered by www.fkjj.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com